Clicking to go to the latest post is weird

Not sure if this is a bug or a feature, but I don’t like it. When I am on “unread” or “latest” and click on the big part of the banner, I end up in the first post of the thread, instead of the unread or latest part of the thread. Then I found out today that if you click on the right side it actually does what I wanted… If you click on the number of posts you even get this funny slider thingie.

I would make a click land you on the latest and that’s it. But I am not even complaining, now that I know that I can click on the right side to do what I want.

Screenshot from 2022-02-28 17-10-07

this one is weird, they changed it and fixed it a few times already - no chance tk change the default behaviour (which is “Juno to latest unread” if it works)

what platform and what browser are you using? I’m on mobile (android + chrome webapp) and it works as it should for me!

firefox on linux

thx i just tried ! i got the 24 feb / 28 feb slider when i click the number. its either first or last post